CentOS7开启BBR拥塞控制算法


2018-10-20 07:06
zpq
38

升级内核

首先查看你的Linux内核版本

uname -a

开启BBR拥塞控制算法的要求是Linux内核4.9以上版本,现在主流的Linux发行版内核还停留在2.x,我们需要先升级Linux内核版本。
首先,我们需要增加一个 ELRepo 源。
首先,让我们添加 ELRepo GPG key:

rpm --import https://www.elrepo.org/RPM-GPG-KEY-elrepo.org 

添加源:

rpm -Uvh https://www.elrepo.org/elrepo-release-7.0-3.el7.elrepo.noarch.rpm

安装 fastestmirror

yum install yum-plugin-fastestmirror

安装最新Kernel

yum --enablerepo=elrepo-kernel install kernel-ml

切换到刚刚下载的新内核

grub2-set-default 0

重启后,通过 uname -a 查看内核是否成功切换到最新的版本,确认后我们进入下一步开启BBR